Trouble installing

Dec 12, 2016 at 9:31 PM
Edited Dec 12, 2016 at 9:33 PM
Our installation of Umbraco is not at the root of our server. We have multiple sites on the same server and in each of them we have an Umbraco install.

http://ourserver/mysite/ root
http://ourserver/mysite/umbraco backend

http://ourserver/myOTHERsite/ root
http://ourserver/myOTHERsite/umbraco backend
etc...

When install full text search from Developer install local package, it installs into a new folder in the parent folder.

That is I expect a file
ourserver/mysite/config/FullTextSearch.config
but it installs into
ourserver/mysite/mysite/config/FullTextSearch.config
note: ^^^^

The other files also install in that folder as well.
ourserver/mysite/mysite/bin/Governor.Umbraco.FullTextSearch.dll
ourserver/mysite/mysite/macroScripts/FullTextSearch.cshtml
ourserver/mysite/mysite/macroScripts/FullTextSearch.cshtml
ourserver/mysite/mysite/umbraco/plugins/FullTextSearch/Dashboard.ascx

The package was installed in Umbraco and in packages you could see full text search however the config file was not in the right place.

I tried moving the files from the ~/mysite/mysite/ folder to the appropriate places in the correct folders so that it now looks like:

ourserver/mysite/bin/Governor.Umbraco.FullTextSearch.dll
ourserver/mysite/macroScripts/FullTextSearch.cshtml
ourserver/mysite/macroScripts/FullTextSearch.cshtml
ourserver/mysite/umbraco/plugins/FullTextSearch/Dashboard.ascx

I think this is the correct locations for everything.

I have made the config modifications recommended in the documentation and now I get ASP errors.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'FullTextSearch' or one of its dependencies. The system cannot find the file specified.

Source Error:


An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Source File: D:\application\apps\ourserver\mysite\config\ExamineSettings.config Line: 25

Assembly Load Trace: The following information can be helpful to determine why the assembly 'FullTextSearch' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

I would really like to get this set up. Does anyone have any ideas?

My next test is to open a sandbox server and install umbraco there and then full text search to see if it works when installed at the root of the server.

email is matt.brown@daimler.com and I would be really happy to get some advice on setup.