How to get useWildcards to work

Aug 5, 2011 at 3:20 AM

Hi,

I am trying to activate wilcards so a search query like "pro**" will match both "property" and "professional", but it seems that changing the useWildcards parameter in the XSLT macro doesn´t have any effect. It still requires an keyword wih exact macth.

Default setting is useWildcards="0". What do I need to change it to? I have tried both useWildcards="1" and useWildcards="*"without any luck:

    <umbraco:Macro queryType="MultiRelevance" titleProperties="" bodyProperties="" titleLinkProperties="" summaryProperties="" rootNodes="" contextHighlighting="1" summaryLength="100" pageLength="1000" fuzzyness="" useWildcards="0" Alias="FullTextSearch" runat="server"></umbraco:Macro>

 

Best regards,

Martin

Coordinator
Aug 5, 2011 at 9:58 AM

Hi Martin,

The useWildcards setting actually appends a wildcard to the end of a query automatically. So typing pro should automatcically match property and professional. I probably should have made that clearer in the documentation.

If you acually type the wildcard it just gets escaped by the query parser. I can look into adding support for user typed wildcards in a future version.

Cheers,

Bjorn

Aug 5, 2011 at 8:46 PM

Hi Bjorn,

Thanks for the quick reply - you pointed me in the right direction (setting useWildcards="1").

I did try it yesterday, actually, but I thought it was wrong since the search result went a bit crazy at the same time I set useWildcards="1". It seems that on my site as soon as useWildcards is set to "1" then a lot of wrong hits appear under the right hits when I search. One thing goes again in all the wrong hits: They link to pages that contain the character "5" (the number five). Not every search query gives these wrong hits. It seems that "5" must appear in the right hit pages too and then the long list of wrong pages (pages not containing my query word) appear also.

I know it sounds weird, but can it be that there is a bug in the package that gives the character "5" a special role?

 

BTW: Thanks for the great package - it has made it possible for me to actually set up Examine! :)

 

Cheers.

Martin

Aug 6, 2011 at 4:42 AM

I will try to explain in another way (the above was a bit confusing....):

 

When ever a search term results in one or more pages containing the character "5" in the <data alias="FullTextSearch"> of the result pages then a lot of extra hits appear on the hits pages: All of the extra pages is characterized by also containing "5" in the <data alias="FullTextSearch"> node.

The same happens, BTW, when I enter a search query that has no matches (i.e. "xxxxxxxxxxxxxxxxxxxxxxxxxxxx" ): Then a lot of wrong hits appear, all of them  containing the character "5" in the <data alias="FullTextSearch">.

 

Hope this makes more sense.... :)

 

Regards,

Martin

Aug 6, 2011 at 5:21 AM

Forgot one last info: "5" is highlighted in the wrong search result even though "5" isn´t part of the search query.

Coordinator
Aug 8, 2011 at 9:38 AM

That certainly sounds like a bug... It's an odd one though. It seems like a 5 is somehow working itself into your lucene queries. I can't picture what would trigger that behaviour though.

I've tried this on my installation and I can't replicate it.

A few thoughts/questions

1) Have you modified the XSLT in any way, is it possible you could have introduced a bug there?

2) Are you using a non-standard language/character set?

3) Can you give me any more details. A copy of the macro from your template? Your fulltextsearch.config? URLs to the problem pages?

 

Bjorn

Aug 8, 2011 at 8:56 PM

Thanks for the ideas on what to try. I´ve tried changing the XSLT back to the original + changed language to <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"> (charset has been utf-8 all the time). But it changes nothing, unfortunately.

I you send me your email til me (umbraco@explizit.dk) I can send you more info: Macro,  fulltextsearch.config? URLs to the problem pages and so on. (site isn´t live yet so I would like to avoid sharing it here for now).

 

But maybe it´s just something unexplainable.... Maybe it helps when I move to production server - I think I will try waiting for that now. And if the problem persists I will try solving again.

But I you will you are welcome to write me and I will send more info.

 

Best regards,

Martin

Jan 23, 2012 at 3:17 PM
Edited Jan 24, 2012 at 8:45 AM

Hi,

I have the same Problem here with "5". After a few weeks with FullTextSearch I have results with highlighted "5" since yesterday. Don't know the reason.

Some one an idea for a fix?

Edit:

Possible solution: http://fulltextsearch.codeplex.com/workitem/535