web service acess

Jul 20, 2011 at 10:22 AM

Hi,

I have tried to use the web service to Reindex, but get an error - "The user (admin) does not have access to this service..."

I have enable web services in config/umbracoSettings. Is there any thing to be configured there ? like service name and user name.

Secondly, where is the Full Text Search Tab in the developer section to trigger a reindex ?

Coordinator
Jul 20, 2011 at 11:12 AM

Hi,

The Full Text search tab should be visible in the back office next to "getting started" at the top of the page in the developer section of the back office. Click on the "Developer" folder at the root of the tree in the left pane if you're not seeing it there. It should appear. If it's not there then there's some kind of bug. Post a screenshot of what you're seeing and I'll investiage further.

To access the webservice you will need to set your user (admin) to have access to maintenance services in the umbracosettings.config, my webservices section looks as follows and seems to work...

 

<!-- configuration for webservices -->
    <!-- webservices are disabled by default. Set enable="True" to enable them -->
    <webservices enabled="True">
        <!-- You must set user-rights for each service. Enter the usernames seperated with comma (,) -->
        <documentServiceUsers>your-username</documentServiceUsers>
        <fileServiceUsers>your-username</fileServiceUsers>
        <stylesheetServiceUsers>your-username</stylesheetServiceUsers>
        <memberServiceUsers>your-username</memberServiceUsers>
        <maintenanceServiceUsers>admin</maintenanceServiceUsers>
        <templateServiceUsers>your-username</templateServiceUsers>
        <!-- type of files (extensions) that are allowed for the file service -->
        <fileServiceFolders>css,xslt</fileServiceFolders>
    </webservices>

Lastly, If you just need to re-create the index it's equally effective to just delete ~\App_Data\TEMP\ExamineIndexes\FullText\ from your web app and publish a page in the back office. That should trigger re-indexing.

Let me know if that helps.

Jul 22, 2011 at 10:13 AM

Hi

Thanks for your response. I located the Full Text Search tab in the back office.. and the

<maintenanceServiceUsers>admin</maintenanceServiceUsers> got the web service working as well.

Regards